summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorLogan Rathbone <poprocks@gmail.com>2023-01-24 14:21:59 -0500
committerLogan Rathbone <poprocks@gmail.com>2023-01-24 14:21:59 -0500
commit9a25ce0f68abd73af9024d48cb7e1925303c2183 (patch)
treeaf4509077d3f58f2d2674ae200614f8176be0610 /meson.build
parent05921d7f6b0dd519b95f1b868e93bafd081237ca (diff)
downloadzenity-9a25ce0f68abd73af9024d48cb7e1925303c2183.tar.gz
text: Re-add webkit support for gtk4
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build17
1 files changed, 8 insertions, 9 deletions
diff --git a/meson.build b/meson.build
index 97d0284..222d264 100644
--- a/meson.build
+++ b/meson.build
@@ -65,15 +65,14 @@ opt_missing_str = '''
Requested optional @0@ support but library not found.
Please ensure you have any required development libraries installed.'''
-# TODO
-#webkitgtk = dependency('webkit2gtk-4.0', version: '>= 2.8.1', required: false)
-#if get_option('webkitgtk')
-# if webkitgtk.found()
-# zenity_conf.set('HAVE_WEBKITGTK', true)
-# else
-# error(opt_missing_str.format('webkitgtk'))
-# endif
-#endif
+webkitgtk_dep = dependency('webkit2gtk-5.0', required: false)
+if get_option('webkitgtk')
+ if webkitgtk_dep.found()
+ zenity_conf.set('HAVE_WEBKITGTK', true)
+ else
+ error(opt_missing_str.format('webkitgtk'))
+ endif
+endif
configure_file(
output: 'config.h',