summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorAdam Williamson <awilliam@redhat.com>2023-04-26 09:44:39 -0700
committerAdam Williamson <awilliam@redhat.com>2023-04-26 11:13:14 -0700
commit15770afebe8aa5e8b367733e1e24c1f08ef10c23 (patch)
tree3116ec59f4f99de6601b7916610b16e50fb67789 /meson.build
parent548ca2f19c8d42fbe62e179f5b1cffc0362b4664 (diff)
downloadzenity-15770afebe8aa5e8b367733e1e24c1f08ef10c23.tar.gz
Port to webkitgtk 6.0
webkitgtk 5.0 is gone from Fedora 38 and Fedora Rawhide, so our CI 'build_fedora' task is always failing. This ports the code to webkitgtk 6.0 and updates the build and CI configs. I based the changes on Epiphany code. I tested it with: zenity --text-info --html --url=https://www.happyassassin.net and it seems to work OK. Signed-off-by: Adam Williamson <awilliam@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index d431809..062fed4 100644
--- a/meson.build
+++ b/meson.build
@@ -65,7 +65,7 @@ opt_missing_str = '''
Requested optional @0@ support but library not found.
Please ensure you have any required development libraries installed.'''
-webkitgtk_dep = dependency('webkit2gtk-5.0', required: false)
+webkitgtk_dep = dependency('webkitgtk-6.0', required: false)
if get_option('webkitgtk')
if webkitgtk_dep.found()
zenity_conf.set('HAVE_WEBKITGTK', true)