summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorShaun McCance <shaunm@gnome.org>2013-11-18 09:57:49 -0500
committerShaun McCance <shaunm@gnome.org>2013-11-18 09:57:49 -0500
commit2e63c1ae0f1bad71c6d7b9bf328f919e6372e719 (patch)
tree123b55a2290ec8a75dc79989397f903b83cf2bad /configure.ac
parent69014c0374ae8acbc0c93b3d43f28264791dca75 (diff)
downloadyelp-tools-2e63c1ae0f1bad71c6d7b9bf328f919e6372e719.tar.gz
Added HELP_MEDIA_NODUP and YELP_INIT_HELP
HELP_MEDIA normally craetes symlinks for localized copies that don't exist, but for images this isn't actually necessary. Yelp can load according to the document path. Don't want to break API on HELP_MEDIA because people use it for a few other things. Hence, HELP_MEDIA_NODUP which works just like HELP_MEDIA, except no symlinks on install. Also, if you use HELP_MEDIA_NODUP and somebody builds with an older yelp.m4, the files are just silently ignored. Added YELP_INIT_HELP to replace YELP_HELP_INIT (though YELP_HELP_INIT is not currently deprecated), and YELP_INIT_HELP is stingy about checking minimum version.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 5ba8caf..924471c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
-AC_INIT([yelp-tools], [3.10.0],
+AC_INIT([yelp-tools], [3.11.1],
[http://bugzilla.gnome.org/enter_bug.cgi?product=yelp-tools])
AM_INIT_AUTOMAKE([1.9 no-dist-gzip dist-bzip2])
@@ -16,6 +16,9 @@ AC_SUBST(GDU_AWK)
AC_PROG_LN_S
+YELP_STABLE_VERSION=$(echo $VERSION | $GDU_AWK '// { split($1, v, "."); print 100 * v[[1]] + (int((v[[2]] + 1) / 2) * 2); }')
+AC_SUBST([YELP_STABLE_VERSION])
+
AC_CHECK_PROG(XMLLINT, xmllint, xmllint)
if test x"$XMLLINT" = x; then
AC_MSG_ERROR([xmllint not found])
@@ -93,6 +96,7 @@ AC_CONFIG_FILES([
Makefile
templates/Makefile
tools/Makefile
+tools/yelp.m4
tools/yelp-build
tools/yelp-check
tools/yelp-new