summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorThomas Kluyver <takowl@gmail.com>2014-09-28 18:44:48 -0700
committerThomas Kluyver <takowl@gmail.com>2014-09-28 18:44:48 -0700
commit182230b2c9b6a3f7bc4a0e6d94ce866c91b4838f (patch)
tree22e0bc9ad6bae25785bfc581fcfbf978581b6fae /setup.py
downloadxstatic-termjs-182230b2c9b6a3f7bc4a0e6d94ce866c91b4838f.tar.gz
Initial commit
term.js version 0.0.4
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py27
1 files changed, 27 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..3896f37
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,27 @@
+from xstatic.pkg import termjs as xs
+
+# The README.txt file should be written in reST so that PyPI can use
+# it to generate your project's PyPI page.
+long_description = open('README.rst').read()
+
+from setuptools import setup, find_packages
+
+setup(
+ name=xs.PACKAGE_NAME,
+ version=xs.PACKAGE_VERSION,
+ description=xs.DESCRIPTION,
+ long_description=long_description,
+ classifiers=xs.CLASSIFIERS,
+ keywords=xs.KEYWORDS,
+ maintainer=xs.MAINTAINER,
+ maintainer_email=xs.MAINTAINER_EMAIL,
+ license=xs.LICENSE,
+ url=xs.HOMEPAGE,
+ platforms=xs.PLATFORMS,
+ packages=find_packages(),
+ namespace_packages=['xstatic', 'xstatic.pkg', ],
+ include_package_data=True,
+ zip_safe=False,
+ install_requires=[], # nothing! :)
+ # if you like, you MAY use the 'XStatic' package.
+)