summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Jones <r1chardj0n3s@gmail.com>2016-09-07 13:30:10 +1000
committerRichard Jones <r1chardj0n3s@gmail.com>2016-09-08 09:46:08 +1000
commit7845a12f0f1e80e34ba953f731bf8bda619d5666 (patch)
treee695674ebf734685b5856db0b387f9b1abf9cbd6
parent4efc42f7473cd6772b1601b1447579e41e0c291f (diff)
downloadxstatic-jasmine-7845a12f0f1e80e34ba953f731bf8bda619d5666.tar.gz
Update with corrected xstatic-release
Also update to replace license placeholder with actual. Change-Id: Ic51be3ac844999041b64e9f1c87ca3ff96bde61f
-rw-r--r--MANIFEST.in4
-rw-r--r--setup.cfg20
-rw-r--r--setup.py5
-rw-r--r--xstatic/pkg/jasmine/__init__.py2
4 files changed, 24 insertions, 7 deletions
diff --git a/MANIFEST.in b/MANIFEST.in
index f7ab2af..af3cdd3 100644
--- a/MANIFEST.in
+++ b/MANIFEST.in
@@ -1,8 +1,6 @@
include README.txt
-recursive-include xstatic/pkg/jasmine *
-
+recursive-include xstatic *
global-exclude *.pyc
global-exclude *.pyo
global-exclude *.orig
global-exclude *.rej
-
diff --git a/setup.cfg b/setup.cfg
new file mode 100644
index 0000000..b3c2adf
--- /dev/null
+++ b/setup.cfg
@@ -0,0 +1,20 @@
+[metadata]
+name = XStatic-Jasmine
+description = Jasmine 2.4.1 (XStatic packaging standard)
+description-file = README.rst
+maintainer = Radomir Dopieralski
+maintainer-email = openstack@sheep.art.pl
+home-page = http://jasmine.github.io/
+keywords = jasmine xstatic
+license = MIT
+zip_safe = False
+namespace_packages =
+ xstatic
+ xstatic.pkg
+
+[files]
+packages =
+ xstatic
+
+[bdist_wheel]
+universal = True
diff --git a/setup.py b/setup.py
index 1fc4082..e27f61b 100644
--- a/setup.py
+++ b/setup.py
@@ -1,11 +1,10 @@
+from setuptools import setup, find_packages
from xstatic.pkg import jasmine as xs
# The README.txt file should be written in reST so that PyPI can use
# it to generate your project's PyPI page.
long_description = open('README.txt').read()
-from setuptools import setup, find_packages
-
setup(
name=xs.PACKAGE_NAME,
version=xs.PACKAGE_VERSION,
@@ -19,7 +18,7 @@ setup(
url=xs.HOMEPAGE,
platforms=xs.PLATFORMS,
packages=find_packages(),
- namespace_packages=['xstatic', 'xstatic.pkg', ],
+ namespace_packages=['xstatic', 'xstatic.pkg'],
include_package_data=True,
zip_safe=False,
install_requires=[],
diff --git a/xstatic/pkg/jasmine/__init__.py b/xstatic/pkg/jasmine/__init__.py
index 0807728..55f40cb 100644
--- a/xstatic/pkg/jasmine/__init__.py
+++ b/xstatic/pkg/jasmine/__init__.py
@@ -31,7 +31,7 @@ MAINTAINER_EMAIL = 'openstack@sheep.art.pl'
HOMEPAGE = 'http://jasmine.github.io/'
# this refers to all files:
-LICENSE = '(same as %s)' % DISPLAY_NAME
+LICENSE = 'MIT'
from os.path import join, dirname
BASE_DIR = join(dirname(__file__), 'data')