summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorRadomir Dopieralski <openstack@sheep.art.pl>2014-05-20 13:31:49 +0200
committerRadomir Dopieralski <openstack@sheep.art.pl>2014-05-20 13:31:49 +0200
commit43052a70a07b666e3f43af32b1697539ff00a444 (patch)
tree161d6a96db412924cad70c5a3cbd2d291572e4ee /setup.py
downloadxstatic-d3-43052a70a07b666e3f43af32b1697539ff00a444.tar.gz
Version 3.1.6 of the D3.js library
Initial version as used by OpenStack's Horizon, packaged for XStatic.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py27
1 files changed, 27 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..ea55db4
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,27 @@
+from xstatic.pkg import d3 as xs
+
+# The README.txt file should be written in reST so that PyPI can use
+# it to generate your project's PyPI page.
+long_description = open('README.txt').read()
+
+from setuptools import setup, find_packages
+
+setup(
+ name=xs.PACKAGE_NAME,
+ version=xs.PACKAGE_VERSION,
+ description=xs.DESCRIPTION,
+ long_description=long_description,
+ classifiers=xs.CLASSIFIERS,
+ keywords=xs.KEYWORDS,
+ maintainer=xs.MAINTAINER,
+ maintainer_email=xs.MAINTAINER_EMAIL,
+ license=xs.LICENSE,
+ url=xs.HOMEPAGE,
+ platforms=xs.PLATFORMS,
+ packages=find_packages(),
+ namespace_packages=['xstatic', 'xstatic.pkg', ],
+ include_package_data=True,
+ zip_safe=False,
+ install_requires=[], # nothing! :)
+ # if you like, you MAY use the 'XStatic' package.
+)