summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Hellmann <doug@doughellmann.com>2016-08-23 13:18:42 -0400
committerRichard Jones <r1chardj0n3s@gmail.com>2016-08-27 08:40:22 +1000
commitf1e92703fc5f2e194ae2e287b2f6fff46d09c7ff (patch)
tree701dd873fc74fb9eaa8091b77f5fb4d2342f72e3
parent9a6a7764317d3a9db530f599d5958d3e14126551 (diff)
downloadxstatic-angular-smart-table-f1e92703fc5f2e194ae2e287b2f6fff46d09c7ff.tar.gz
Fix description metadata
There doesn't seem to be a "summary" option, but "description" and "long_description" are different. Update the metadata to avoid warnings about the unknown "summary" and so that when the release announce script asks for the package description it gets the one line version instead of the longer one. Also, bump the build number as 1.4.13.1 has been released. Change-Id: Ibe475d90c97f6e0c09be92c211924546d7d8cca1 Signed-off-by: Doug Hellmann <doug@doughellmann.com>
-rw-r--r--setup.cfg2
-rw-r--r--setup.py4
-rw-r--r--xstatic/pkg/angular_smart_table/__init__.py2
3 files changed, 4 insertions, 4 deletions
diff --git a/setup.cfg b/setup.cfg
index fe4580e..8dd87a8 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -1,6 +1,6 @@
[metadata]
name = XStatic-smart-table
-summary = smart-table 1.4.13 (XStatic packaging standard)
+description = smart-table 1.4.13 (XStatic packaging standard)
description-file = README.rst
maintainer = Richard Jones
maintainer-email = r1chardj0n3s@gmail.com
diff --git a/setup.py b/setup.py
index 47062a9..873feaf 100644
--- a/setup.py
+++ b/setup.py
@@ -6,8 +6,8 @@ long_description = open('README.txt').read()
setup(
name='XStatic-smart-table',
- summary="""smart-table 1.4.13 (XStatic packaging standard)""",
- description=long_description,
+ description="""smart-table 1.4.13 (XStatic packaging standard)""",
+ long_description=long_description,
maintainer="Richard Jones",
maintainer_email='r1chardj0n3s@gmail.com',
use_scm_version=True,
diff --git a/xstatic/pkg/angular_smart_table/__init__.py b/xstatic/pkg/angular_smart_table/__init__.py
index e910dd3..b7db1ab 100644
--- a/xstatic/pkg/angular_smart_table/__init__.py
+++ b/xstatic/pkg/angular_smart_table/__init__.py
@@ -17,7 +17,7 @@ NAME = __name__.split('.')[-1] # package name (e.g. 'foo' or 'foo_bar')
VERSION = '1.4.13' # version of the packaged files, please use the upstream
# version number
-BUILD = '1' # our package build number, so we can release new builds
+BUILD = '2' # our package build number, so we can release new builds
# with fixes for xstatic stuff.
PACKAGE_VERSION = VERSION + '.' + BUILD # version used for PyPi