summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJenkins <jenkins@review.openstack.org>2016-06-24 01:27:31 +0000
committerGerrit Code Review <review@openstack.org>2016-06-24 01:27:31 +0000
commit6a9182ab0001215cf5f0c41356f98c88202f48e7 (patch)
treeb2c342107f88acb396b73f8320d53315299ba5d4 /setup.py
parent8648295573aa0fd887a36684fde84c9c504a4b1e (diff)
parenteebdf56d4fe62c8aeb07d771f212d809a43e0598 (diff)
downloadxstatic-angular-bootstrap-6a9182ab0001215cf5f0c41356f98c88202f48e7.tar.gz
Merge "Update to use setuptools_scm for release version generation"0.11.0.4
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py28
1 files changed, 4 insertions, 24 deletions
diff --git a/setup.py b/setup.py
index 5458a9e..b680c15 100644
--- a/setup.py
+++ b/setup.py
@@ -1,27 +1,7 @@
-from xstatic.pkg import angular_bootstrap as xs
-
-# The README.txt file should be written in reST so that PyPI can use
-# it to generate your project's PyPI page.
-long_description = open('README.txt').read()
-
from setuptools import setup, find_packages
-
setup(
- name=xs.PACKAGE_NAME,
- version=xs.PACKAGE_VERSION,
- description=xs.DESCRIPTION,
- long_description=long_description,
- classifiers=xs.CLASSIFIERS,
- keywords=xs.KEYWORDS,
- maintainer=xs.MAINTAINER,
- maintainer_email=xs.MAINTAINER_EMAIL,
- license=xs.LICENSE,
- url=xs.HOMEPAGE,
- platforms=xs.PLATFORMS,
- packages=find_packages(),
- namespace_packages=['xstatic', 'xstatic.pkg', ],
- include_package_data=True,
- zip_safe=False,
- install_requires=[], # nothing! :)
- # if you like, you MAY use the 'XStatic' package.
+ name='XStatic-Angular-Bootstrap',
+ use_scm_version=True,
+ setup_requires=['setuptools_scm', 'wheel'],
+ packages=find_packages()
)