summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMaxime Vidori <maxime.vidori@gmail.com>2014-08-18 11:21:02 +0200
committerMaxime Vidori <maxime.vidori@gmail.com>2014-08-18 14:21:44 +0200
commit2a8c157b8b0733afbfdaf7eea29cf012a8b7f483 (patch)
tree9aae9da0951278ae554a70ad0e52d2dc2d4bcc6c /setup.py
downloadxstatic-angular-bootstrap-2a8c157b8b0733afbfdaf7eea29cf012a8b7f483.tar.gz
Version 0.11.0 of Angular-Boostrap
Change-Id: I79ecf33979530e23598c60364fdbbcf6d97d4882
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py27
1 files changed, 27 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..5458a9e
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,27 @@
+from xstatic.pkg import angular_bootstrap as xs
+
+# The README.txt file should be written in reST so that PyPI can use
+# it to generate your project's PyPI page.
+long_description = open('README.txt').read()
+
+from setuptools import setup, find_packages
+
+setup(
+ name=xs.PACKAGE_NAME,
+ version=xs.PACKAGE_VERSION,
+ description=xs.DESCRIPTION,
+ long_description=long_description,
+ classifiers=xs.CLASSIFIERS,
+ keywords=xs.KEYWORDS,
+ maintainer=xs.MAINTAINER,
+ maintainer_email=xs.MAINTAINER_EMAIL,
+ license=xs.LICENSE,
+ url=xs.HOMEPAGE,
+ platforms=xs.PLATFORMS,
+ packages=find_packages(),
+ namespace_packages=['xstatic', 'xstatic.pkg', ],
+ include_package_data=True,
+ zip_safe=False,
+ install_requires=[], # nothing! :)
+ # if you like, you MAY use the 'XStatic' package.
+)