summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorRadomir Dopieralski <openstack@sheep.art.pl>2014-06-02 14:39:16 +0200
committerRadomir Dopieralski <openstack@sheep.art.pl>2014-06-02 14:39:16 +0200
commit4f3398263a17831ec26e2d42e7e89ba099e4ea64 (patch)
tree6dfb6b6f5415dfb9d73a0e9304f7452bac0c4cb2 /setup.py
parent2580d7a797cd5dce16a867eee64125efdb60f712 (diff)
downloadxstatic-git-4f3398263a17831ec26e2d42e7e89ba099e4ea64.tar.gz
Proper path to README.txt in setup.py
The setup.py will fail when invoked from any other working directory than the main directory of the project. This can be problematic for some deployment tools. Ideally, setup.py should contain no code.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 5 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 8633c85..4c7d7d6 100644
--- a/setup.py
+++ b/setup.py
@@ -7,9 +7,13 @@ XStatic - setup.py
Works with: setuptools
"""
+import os.path
# The README.txt file should be written in reST so that PyPI can use
# it to generate your project's PyPI page.
-long_description = open('README.txt').read()
+readme_path = os.path.join(os.path.dirname(os.path.abspath(__file__)),
+ 'README.txt')
+with open(readme_path) as f:
+ long_description = f.read()
from setuptools import setup, find_packages