summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorThomas Waldmann <tw AT waldmann-edv DOT de@localhost>2011-06-26 07:23:14 +0200
committerThomas Waldmann <tw AT waldmann-edv DOT de@localhost>2011-06-26 07:23:14 +0200
commit0c0b0618b919833b47ad4da8e011c60304347b01 (patch)
tree0b1faf97b59cae918e8289133414dcd162f5e3f0 /setup.py
parent096bc018cb93be2ed4799e03c6d42b812fced4e2 (diff)
downloadxstatic-git-0c0b0618b919833b47ad4da8e011c60304347b01.tar.gz
setup.py: make namespace packages work, add missing stuff
add url and namespaces_packages decl use 1-line __init__.py for xstatic and xstatic.pkg namespace packages move most of the code to xstatic.main
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 2 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 9e802bf..a2137fd 100644
--- a/setup.py
+++ b/setup.py
@@ -23,8 +23,10 @@ setup(
keywords=[],
author='Thomas Waldmann',
author_email='tw@waldmann-edv.de',
+ url='http:/bitbucket.org/thomaswaldmann/xstatic',
license='MIT license',
packages=find_packages(),
+ namespace_packages=['xstatic', 'xstatic.pkg', ],
include_package_data=True,
zip_safe=False,
install_requires=[], # there should never be a dependency!