summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 0ecfd7f..6cf0e3a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -7,6 +7,10 @@ AC_INIT([makedepend], [1.0.8],
[https://gitlab.freedesktop.org/xorg/util/makedepend/-/issues])
AC_CONFIG_SRCDIR([Makefile.am])
AC_CONFIG_HEADERS([makedepend-config.h])
+# Set common system defines for POSIX extensions, such as _GNU_SOURCE
+# Must be called before any macros that run the compiler (like AC_PROG_LIBTOOL)
+# to avoid autoconf errors.
+AC_USE_SYSTEM_EXTENSIONS
# Initialize Automake
AM_INIT_AUTOMAKE([foreign dist-xz])
@@ -21,7 +25,7 @@ XORG_DEFAULT_OPTIONS
XORG_WITH_LINT
dnl Checks for functions
-AC_CHECK_FUNCS([rename fchmod])
+AC_CHECK_FUNCS([rename fchmod reallocarray])
dnl Use 64-bit file operations on 32-bit systems that support them
AC_SYS_LARGEFILE