summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlan Coopersmith <Alan.Coopersmith@sun.com>2005-05-15 21:16:24 +0000
committerAlan Coopersmith <Alan.Coopersmith@sun.com>2005-05-15 21:16:24 +0000
commitb0e61cfcfbb56696597eb65511c74ad901d62b58 (patch)
tree85f45e3b280d40dd42cf3ffe8a2460ec4ed104c7 /configure.ac
parentdabc4c7abcba043e206745bdb101aafb48c00c71 (diff)
downloadxorg-util-makedepend-b0e61cfcfbb56696597eb65511c74ad901d62b58.tar.gz
Initial attempt at autotooling/modular conversion of makedepend
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 19 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..a7288b0
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,19 @@
+dnl $XdotOrg: $
+AC_PREREQ([2.57])
+AC_INIT([makedepend], [7.0], [xorg@lists.freedesktop.org])
+AM_INIT_AUTOMAKE([foreign dist-bzip2])
+AM_CONFIG_HEADER([makedepend-config.h])
+
+dnl Checks for programs.
+AC_PROG_CC
+
+dnl Replacement for Imake SIGNAL_DEFINES
+AC_TYPE_SIGNAL
+
+dnl Checks for functions
+AC_CHECK_FUNCS([rename fchmod])
+
+dnl Use 64-bit file operations on 32-bit systems that support them
+AC_SYS_LARGEFILE
+
+AC_OUTPUT([Makefile])