summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJames Cloos <cloos@jhcloos.com>2007-12-06 16:38:53 -0500
committerJames Cloos <cloos@jhcloos.com>2007-12-06 16:38:53 -0500
commit4505577c4d6b5d32c276366ce6bc3eda1cd59ad7 (patch)
treee5f993ac9296d52aa41d3ad763e16688c214ef76 /Makefile.am
parent492cd9bfc642443d92f419964334f59b89329a36 (diff)
downloadxorg-lib-libxkbfile-4505577c4d6b5d32c276366ce6bc3eda1cd59ad7.tar.gz
Replace static ChangeLog with dist-hook to generate from git log
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 5df3025..14028f2 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -25,3 +25,13 @@ pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = xkbfile.pc
EXTRA_DIST = xkbfile.pc.in autogen.sh
+
+EXTRA_DIST += ChangeLog
+MAINTAINERCLEANFILES = ChangeLog
+
+.PHONY: ChangeLog
+
+ChangeLog:
+ (GIT_DIR=$(top_srcdir)/.git git-log > .changelog.tmp && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) || (touch ChangeLog; echo 'git directory not found: installing possibly empty changelog.' >&2)
+
+dist-hook: ChangeLog