summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPeter Hutterer <peter.hutterer@who-t.net>2020-07-08 12:35:23 +1000
committerRan Benita <ran@unusedvar.com>2020-07-25 11:05:14 +0300
commit76d847ac24137de081308e503311ff784b294805 (patch)
tree4221099f696292f956cb26a062ffcc714dffe157 /meson.build
parent90ece8fb0af8111e0b0f2e17801ec927edb38be6 (diff)
downloadxorg-lib-libxkbcommon-76d847ac24137de081308e503311ff784b294805.tar.gz
meson.build: move the config.h generation to the bottom
We cannot add to configh_data after this command so let's generate this last. Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 7de7702..30f8abc 100644
--- a/meson.build
+++ b/meson.build
@@ -129,8 +129,6 @@ configh_data.set('_CRT_NONSTDC_NO_WARNINGS', 1)
configh_data.set('_CRT_NONSTDC_NO_DEPRECATE', 1)
# Reduce unnecessary includes on MSVC.
configh_data.set('WIN32_LEAN_AND_MEAN', 1)
-configure_file(output: 'config.h', configuration: configh_data)
-
# Supports -Wl,--version-script?
have_version_script = cc.links(
@@ -677,3 +675,5 @@ You can disable the documentation with -Denable-docs=false.''')
build_by_default: true,
)
endif
+
+configure_file(output: 'config.h', configuration: configh_data)