summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorSamuel Thibault <samuel.thibault@ens-lyon.org>2010-01-19 18:37:43 +0100
committerJulien Cristau <jcristau@debian.org>2010-02-10 00:49:38 +0100
commitaf2be74979aeab9a2fc4c933462e97ce70f816b6 (patch)
tree5d1e3fd215e783fbaba73817f5a505c8e4f00d85 /src/Makefile.am
parentebb3c6b69f4e8a844ff95d4e880dde9ede3de347 (diff)
downloadxorg-lib-libpciaccess-af2be74979aeab9a2fc4c933462e97ce70f816b6.tar.gz
libpciaccess x86 backend
This adds support on x86 for OSes that do not have a PCI interface, tinkering with I/O ports, and makes use of it on GNU/Hurd. Signed-off-by: Julien Cristau <jcristau@debian.org>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 4c06c25..8afd53b 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -51,6 +51,10 @@ else
VGA_ARBITER = common_vgaarb_stub.c
endif
+if GNU
+OS_SUPPORT = x86_pci.c
+endif
+
libpciaccess_la_SOURCES = common_bridge.c \
common_iterator.c \
common_init.c \