summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMark Kettenis <mark.kettenis@xs4all.nl>2011-11-06 17:34:29 +0000
committerMatthieu Herrb <matthieu.herrb@laas.fr>2011-11-19 15:44:43 +0100
commit2601ddd02d608c16b0022fe342e0a3f4bf6cadeb (patch)
tree3106a0206fe3d8ae5b668947cbdc4190f7990105 /src/Makefile.am
parente64ee4ee2b23dba147d144aacead3cb61c744854 (diff)
downloadxorg-lib-libpciaccess-2601ddd02d608c16b0022fe342e0a3f4bf6cadeb.tar.gz
Add VGA Arbiter support for OpenBSD.
Signed-off-by: Matthieu Herrb <matthieu.herrb@laas.fr>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am10
1 files changed, 5 insertions, 5 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 6757a6f..13a7d94 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -28,32 +28,32 @@ lib_LTLIBRARIES = libpciaccess.la
if LINUX
OS_SUPPORT = linux_sysfs.c linux_devmem.c linux_devmem.h
+VGA_ARBITER = common_vgaarb.c
endif
if FREEBSD
OS_SUPPORT = freebsd_pci.c
+VGA_ARBITER = common_vgaarb_stub.c
endif
if NETBSD
OS_SUPPORT = netbsd_pci.c
+VGA_ARBITER = common_vgaarb_stub.c
endif
if OPENBSD
OS_SUPPORT = openbsd_pci.c
+# VGA Arbiter code is included in openbsd_pci.c
endif
if SOLARIS
OS_SUPPORT = solx_devfs.c pci_tools.h
-endif
-
-if LINUX
-VGA_ARBITER = common_vgaarb.c
-else
VGA_ARBITER = common_vgaarb_stub.c
endif
if GNU
OS_SUPPORT = x86_pci.c
+VGA_ARBITER = common_vgaarb_stub.c
endif
libpciaccess_la_SOURCES = common_bridge.c \