summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorIan Romanick <idr@us.ibm.com>2007-08-30 17:52:02 -0700
committerIan Romanick <idr@us.ibm.com>2007-08-30 17:52:19 -0700
commit08ff9f7fbd26dd2d0e30351b556c71c272f6be6c (patch)
tree0c4849c43518d4d172b4a1f409a8e35579b13e23 /src/Makefile.am
parentc87273e8e20c8bff892ded31295dba103f27dd35 (diff)
downloadxorg-lib-libpciaccess-08ff9f7fbd26dd2d0e30351b556c71c272f6be6c.tar.gz
New interfaces to map memory with MTRR (or similar) support.
Added new functions pci_device_map_range and pci_device_unmap_range to handle mapping of PCI device BARs. These new interfaces allow the possiblity of MTRRs on platforms that support them. These additional APIs necessitated changing some internal interfaces. The code for FreeBSD and Solaris has been updated but has not been compiled or tested. Old interfaces are marked deprecated and will eventually be removed.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 11e3145..e743dbf 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -43,6 +43,7 @@ libpciaccess_la_SOURCES = common_bridge.c \
common_interface.c \
common_capability.c \
common_device_name.c \
+ common_map.c \
pciaccess_private.h \
$(OS_SUPPORT)
@@ -50,7 +51,7 @@ INCLUDES = -I$(top_srcdir)/include
libpciaccess_la_LIBADD = @PCIACCESS_LIBS@
-libpciaccess_la_LDFLAGS = -version-number 0:8:0 -no-undefined
+libpciaccess_la_LDFLAGS = -version-number 0:10:0 -no-undefined
libpciaccessincludedir = $(includedir)
libpciaccessinclude_HEADERS = \