summaryrefslogtreecommitdiff
path: root/scanpci/Makefile.am
diff options
context:
space:
mode:
authorGaetan Nadon <memsize@videotron.ca>2010-08-22 08:10:23 -0400
committerGaetan Nadon <memsize@videotron.ca>2010-10-03 14:02:44 -0400
commitdcb79a20cba1eaaa83158b80bb538d50b003bd79 (patch)
treea008d7a865b261e973541937980bd1e5bf3f36b5 /scanpci/Makefile.am
parent555772964820d88f9481eb48d0431dddd8ba7aa5 (diff)
downloadxorg-lib-libpciaccess-dcb79a20cba1eaaa83158b80bb538d50b003bd79.tar.gz
config: provide a makefile for scanpci dev tool
No function changes. Note that automake generates a wrapper script if libpciaccess is not installed at configuration time, which is the most common case. If it is installed at configuration time, you get an executable. The makefile build order ensures the lib is build before scanpci. Reviewed-by: RĂ©mi Cardona <remi@gentoo.org> Signed-off-by: Gaetan Nadon <memsize@videotron.ca>
Diffstat (limited to 'scanpci/Makefile.am')
-rw-r--r--scanpci/Makefile.am29
1 files changed, 29 insertions, 0 deletions
diff --git a/scanpci/Makefile.am b/scanpci/Makefile.am
new file mode 100644
index 0000000..6fdf86e
--- /dev/null
+++ b/scanpci/Makefile.am
@@ -0,0 +1,29 @@
+#
+# (C) Copyright IBM Corporation 2006
+# All Rights Reserved.
+#
+# Permission is hereby granted, free of charge, to any person obtaining a
+# copy of this software and associated documentation files (the "Software"),
+# to deal in the Software without restriction, including without limitation
+# on the rights to use, copy, modify, merge, publish, distribute, sub
+# license, and/or sell copies of the Software, and to permit persons to whom
+# the Software is furnished to do so, subject to the following conditions:
+#
+# The above copyright notice and this permission notice (including the next
+# paragraph) shall be included in all copies or substantial portions of the
+# Software.
+#
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+# FITNESS FOR A PARTICULAR PURPOSE AND NON-INFRINGEMENT. IN NO EVENT SHALL
+# IBM AND/OR THEIR SUPPLIERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
+# FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
+# DEALINGS IN THE SOFTWARE.
+
+noinst_PROGRAMS = scanpci
+
+AM_CPPFLAGS = -I$(top_srcdir)/include
+AM_LDFLAGS = -L$(top_builddir)/src -lpciaccess
+
+scanpci_SOURCES = scanpci.c