summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am46
1 files changed, 46 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..658307d
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,46 @@
+# Daniel Stone disowns all copyright on this file.
+
+lib_LTLIBRARIES=libXpm.la
+
+AM_CFLAGS = -I. \
+ -I$(top_srcdir)/include/X11/ \
+ $(XPM_CFLAGS)
+
+libXpm_la_LDFLAGS = -version-number 4:5:1 -no-undefined
+libXpm_la_LIBADD = $(XPM_LIBS)
+
+libXpm_la_SOURCES = \
+ Attrib.c \
+ CrBufFrI.c \
+ CrBufFrP.c \
+ CrDatFrI.c \
+ CrDatFrP.c \
+ CrIFrBuf.c \
+ CrIFrDat.c \
+ CrIFrP.c \
+ CrPFrBuf.c \
+ CrPFrDat.c \
+ CrPFrI.c \
+ Image.c \
+ Info.c \
+ RdFToBuf.c \
+ RdFToDat.c \
+ RdFToI.c \
+ RdFToP.c \
+ WrFFrBuf.c \
+ WrFFrDat.c \
+ WrFFrI.c \
+ WrFFrP.c \
+ XpmI.h \
+ create.c \
+ data.c \
+ hashtab.c \
+ misc.c \
+ parse.c \
+ rgb.c \
+ rgbtab.h \
+ scan.c \
+ simx.h
+
+libXpmincludedir = $(includedir)/X11
+libXpminclude_HEADERS = $(top_srcdir)/include/X11/xpm.h