summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@oracle.com>2013-08-02 22:22:09 -0700
committerAlan Coopersmith <alan.coopersmith@oracle.com>2013-08-02 22:32:48 -0700
commit9e38750da16c6e5bd8bb26b00d74041ddf9be3e8 (patch)
treeb7291a8210501d0d7a567c26542e92462b58aa2c /configure.ac
parent93f900ceac7ac899e00998adc8782ed02b352930 (diff)
downloadxorg-lib-libXpm-9e38750da16c6e5bd8bb26b00d74041ddf9be3e8.tar.gz
Add noreturn attributes suggested by gcc
Remove extra bogus return added to avoid warnings when calling Punt() since gcc didn't know it would never return. Signed-off-by: Alan Coopersmith <alan.coopersmith@oracle.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index fdf0986..8946550 100644
--- a/configure.ac
+++ b/configure.ac
@@ -24,7 +24,8 @@ AC_CHECK_FUNCS([strlcat])
# Obtain compiler/linker options for dependencies
PKG_CHECK_MODULES(XPM, xproto x11)
-PKG_CHECK_MODULES(SXPM, x11 xt xext xextproto, build_sxpm=true, build_sxpm=false)
+PKG_CHECK_MODULES(SXPM, [x11 xt xext xextproto xproto >= 7.0.17],
+ [build_sxpm=true], [build_sxpm=false])
AM_CONDITIONAL(BUILD_SXPM, test x$build_sxpm = xtrue)
# Internationalization & localization support