summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGaetan Nadon <memsize@videotron.ca>2010-10-14 21:56:21 -0400
committerGaetan Nadon <memsize@videotron.ca>2010-10-14 21:56:21 -0400
commit78bca7e85b930593fefe85cc51b5e24f98de31d0 (patch)
tree9ea81c301243ed8193edc2a8642ada9291f4ae7b /configure.ac
parent8e47c819490331c01959332e067f06a382d9a14a (diff)
downloadxorg-lib-libXpm-78bca7e85b930593fefe85cc51b5e24f98de31d0.tar.gz
config: fix warnings, m4 quoting and layout
Fix some m4 quoting Fix some autoconf warnings Regroup statements per section Add comments Signed-off-by: Gaetan Nadon <memsize@videotron.ca>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 14 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index 44d9e56..7dbf061 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,26 +1,33 @@
+# Initialize Autoconf
AC_PREREQ([2.60])
-AC_INIT([libXpm], 3.5.8, [https://bugs.freedesktop.org/enter_bug.cgi?product=xorg], libXpm)
+AC_INIT([libXpm],
+ [3.5.8],
+ [https://bugs.freedesktop.org/enter_bug.cgi?product=xorg],
+ [libXpm])
AC_CONFIG_SRCDIR([Makefile.am])
AC_CONFIG_MACRO_DIR([m4])
AC_CONFIG_HEADERS([config.h])
+# Initialize Automake
AM_INIT_AUTOMAKE([foreign dist-bzip2])
AM_MAINTAINER_MODE
+# Initialize libtool
+AC_PROG_LIBTOOL
+
# Require X.Org macros 1.8 or later for MAN_SUBSTS set by XORG_MANPAGE_SECTIONS
m4_ifndef([XORG_MACROS_VERSION],
[m4_fatal([must install xorg-macros 1.8 or later before running autoconf/autogen])])
XORG_MACROS_VERSION(1.8)
XORG_DEFAULT_OPTIONS
-# Checks for programs.
-AC_PROG_LIBTOOL
+# Checks for library functions
+AC_CHECK_FUNCS([strlcat])
-# Checks for pkg-config packages
+# Obtain compiler/linker options for dependencies
PKG_CHECK_MODULES(XPM, xproto x11)
-
-# Checks for functions
-AC_CHECK_FUNCS([strlcat])
+PKG_CHECK_MODULES(SXPM, xt xext xextproto, build_sxpm=true, build_sxpm=false)
+AM_CONDITIONAL(BUILD_SXPM, test x$build_sxpm = xtrue)
# Internationalization & localization support
AC_SEARCH_LIBS([gettext], [intl], [USE_GETTEXT="yes"], [USE_GETTEXT="no"])
@@ -52,9 +59,6 @@ if test x$STAT_ZFILE = xyes ; then
AC_DEFINE(STAT_ZFILE, 1, [Define to 1 to automatically look for files with .Z & .gz extensions])
fi
-PKG_CHECK_MODULES(SXPM, xt xext xextproto, build_sxpm=true, build_sxpm=false)
-AM_CONDITIONAL(BUILD_SXPM, test x$build_sxpm = xtrue)
-
AC_CONFIG_FILES([Makefile
src/Makefile
sxpm/Makefile