summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@oracle.com>2023-01-19 12:16:26 -0800
committerAlan Coopersmith <alan.coopersmith@oracle.com>2023-01-23 15:37:52 -0800
commit71d7149cb356b96cc83e2ec95d06df4022039e2c (patch)
tree546f751fc1093c64bb555f45d9ec4cc216346fc6 /configure.ac
parent9bc32a1a9c788eed2982d3fd35f2295a95af3817 (diff)
downloadxorg-lib-libXpm-71d7149cb356b96cc83e2ec95d06df4022039e2c.tar.gz
configure: correct error message to suggest --disable-open-zfile
When one of the compression helper programs is not found, the message suggesting how to compile without it should say --disable-open-zfile, not --disable-stat-zfile. Fixes: 515294b ("Fix CVE-2022-4883: compression commands depend on $PATH") Closes: #4 Signed-off-by: Alan Coopersmith <alan.coopersmith@oracle.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index d609b02..61a5f08 100644
--- a/configure.ac
+++ b/configure.ac
@@ -53,7 +53,7 @@ dnl Helper macro to find absolute path to program and add a #define for it
AC_DEFUN([XPM_PATH_PROG],[
AC_PATH_PROG([$1], [$2], [])
AS_IF([test "x$$1" = "x"],
- [AC_MSG_ERROR([$2 not found, set $1 or use --disable-stat-zfile])])
+ [AC_MSG_ERROR([$2 not found, set $1 or use --disable-open-zfile])])
AC_DEFINE_UNQUOTED([$1], ["$$1"], [Path to $2])
]) dnl End of AC_DEFUN([XPM_PATH_PROG]...