summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJon TURNEY <jon.turney@dronecode.org.uk>2012-01-02 22:45:53 +0000
committerJon TURNEY <jon.turney@dronecode.org.uk>2012-10-27 15:51:09 +0100
commit4ca8014afbb66f0b65cdcd8ea12e469f52c8c70c (patch)
treeed539fe490b6f7c91bdf303ccd48ccfcfd09a165 /configure.ac
parentacaaea96776b36c097d5413040c5ce85d3ae6cb9 (diff)
downloadxorg-lib-libXpm-4ca8014afbb66f0b65cdcd8ea12e469f52c8c70c.tar.gz
Define NO_ZPIPE when building for MinGW
Define NO_ZPIPE when building for MinGW, decompressing via a pipe isn't implemented. (since xpmPipeThrough() is only written in terms of fork() currently...) Signed-off-by: Jon TURNEY <jon.turney@dronecode.org.uk> Reviewed-by: Colin Harrison <colin.harrison@virgin.net> Reviewed-by: Yaakov Selkowitz <yselkowitz@users.sourceforge.net> Reviewed-by: Ángel González <ingenit@zoho.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ba7e3b4..5ac5d05 100644
--- a/configure.ac
+++ b/configure.ac
@@ -58,6 +58,15 @@ if test x$STAT_ZFILE = xyes ; then
AC_DEFINE(STAT_ZFILE, 1, [Define to 1 to automatically look for files with .Z & .gz extensions])
fi
+
+case $host_os in
+ *mingw*)
+ AC_DEFINE(NO_ZPIPE, 1, [Define to 1 to disable decompression via pipes])
+ ;;
+ *)
+ ;;
+esac
+
AC_CONFIG_FILES([Makefile
doc/Makefile
include/Makefile