summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSøren Sandmann Pedersen <sandmann@daimi.au.dk>2005-05-19 15:02:48 +0000
committerSøren Sandmann Pedersen <sandmann@daimi.au.dk>2005-05-19 15:02:48 +0000
commit2cc1896c61eef5739bb6a8ffa89e58ba5c175a05 (patch)
treec35aba25e7027ae060d3349f37d00474338591f6 /configure.ac
parentcf0d69c7ace679f27f105c582760b9be14923aba (diff)
downloadxorg-lib-libXpm-2cc1896c61eef5739bb6a8ffa89e58ba5c175a05.tar.gz
- Add Xpm to symlink.sh - Conditionally include config.h in xc/extras/Xpm
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac40
1 files changed, 40 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..07dd683
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,40 @@
+AC_PREREQ(2.57)
+AC_INIT([libXpm], 3.5.2, [daniel@freedesktop.org], libXpm)
+AC_CONFIG_SRCDIR([Makefile.am])
+AM_INIT_AUTOMAKE([dist-bzip2])
+
+AM_MAINTAINER_MODE
+
+AM_CONFIG_HEADER([config.h])
+
+# Checks for programs.
+AC_PROG_LIBTOOL
+AC_PROG_CC
+
+# Checks for pkg-config packages
+PKG_CHECK_MODULES(XPM, xproto x11)
+AC_SUBST(XPM_CFLAGS)
+AC_SUBST(XPM_LIBS)
+
+# Checks for header files.
+AC_HEADER_STDC
+
+# Checks for typedefs, structures, and compiler characteristics.
+
+if test "x$GCC" = "xyes"; then
+ GCC_WARNINGS="-Wall -Wpointer-arith -Wstrict-prototypes \
+ -Wmissing-prototypes -Wmissing-declarations \
+ -Wnested-externs -fno-strict-aliasing"
+ CFLAGS="$GCC_WARNINGS $CFLAGS"
+fi
+
+
+PKG_CHECK_MODULES(SXPM, xt xext, build_sxpm=true, build_sxpm=false)
+
+AM_CONDITIONAL(BUILD_SXPM, test x$build_sxpm = xtrue)
+
+AC_OUTPUT([Makefile
+ src/Makefile
+ sxpm/Makefile
+ cxpm/Makefile
+ xpm.pc])