summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJames Cloos <cloos@jhcloos.com>2007-12-06 16:38:36 -0500
committerJames Cloos <cloos@jhcloos.com>2007-12-06 16:38:36 -0500
commit503843fd3066031adbd4a362c686acc721787b7d (patch)
tree55d6a46d26773922d0a35ebe49051e244fdea4d0 /Makefile.am
parent3e37dd39b6169af9928d5b959c40ba79a07450ee (diff)
downloadxorg-lib-libXpm-503843fd3066031adbd4a362c686acc721787b7d.tar.gz
Replace static ChangeLog with dist-hook to generate from git log
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 2a9ca64..a3890f7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -15,3 +15,13 @@ EXTRA_DIST = \
README.AMIGA \
README.html \
README.MSW
+
+EXTRA_DIST += ChangeLog
+MAINTAINERCLEANFILES = ChangeLog
+
+.PHONY: ChangeLog
+
+ChangeLog:
+ (GIT_DIR=$(top_srcdir)/.git git-log > .changelog.tmp && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) || (touch ChangeLog; echo 'git directory not found: installing possibly empty changelog.' >&2)
+
+dist-hook: ChangeLog