summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorGaetan Nadon <memsize@videotron.ca>2010-02-16 10:37:21 -0500
committerGaetan Nadon <memsize@videotron.ca>2010-02-16 10:37:21 -0500
commit00e9520738c8660451cdf21e5a3b530924855822 (patch)
tree62443488c6b84bafd900d5db6b3fa207dd22dce1 /src/Makefile.am
parent0b90e128718f269be334b9e60aa5b50604b1dc8c (diff)
downloadxorg-lib-libXScrnSaver-00e9520738c8660451cdf21e5a3b530924855822.tar.gz
config: move CWARNFLAGS from configure.ac to Makefile.am
Compiler warning flags should be explicitly set in the makefile rather than being merged with other packages compiler flags. Signed-off-by: Gaetan Nadon <memsize@videotron.ca>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index b0498be..aa923b1 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -2,7 +2,8 @@ AM_CFLAGS = -I$(top_srcdir)/include \
-I$(top_srcdir)/include/X11 \
-I$(top_srcdir)/include/X11/extensions \
$(XSCRNSAVER_CFLAGS) \
- $(MALLOC_ZERO_CFLAGS)
+ $(MALLOC_ZERO_CFLAGS) \
+ $(CWARNFLAGS)
lib_LTLIBRARIES = libXss.la