summaryrefslogtreecommitdiff
path: root/nls/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@oracle.com>2010-09-11 00:49:21 -0700
committerAlan Coopersmith <alan.coopersmith@oracle.com>2010-09-21 18:22:21 -0700
commit3eb064071695ebf0f371163ed818a428dfeba8e6 (patch)
tree3a1ec58a3c9221cdcfdaf49d45d0dddf73ce516f /nls/Makefile.am
parenta3fc78ac352e5a70a958996ef6aec50f653974d1 (diff)
downloadxorg-lib-libX11-3eb064071695ebf0f371163ed818a428dfeba8e6.tar.gz
Make locale data build non-recursive / parallelizable
On a 4 core CPU with gmake -j 16 the nls subdir builds in half the time, plus this simplifies the next set of changes. Signed-off-by: Alan Coopersmith <alan.coopersmith@oracle.com> Reviewed-by: Mikhail Gusarov <dottedmag@dottedmag.net> Reviewed-by: James Cloos <cloos@jhcloos.com> Tested-by: Gaetan Nadon <memsize@videotron.ca>
Diffstat (limited to 'nls/Makefile.am')
-rw-r--r--nls/Makefile.am22
1 files changed, 21 insertions, 1 deletions
diff --git a/nls/Makefile.am b/nls/Makefile.am
index 076bf31a..8247207a 100644
--- a/nls/Makefile.am
+++ b/nls/Makefile.am
@@ -11,7 +11,7 @@ CLEANFILES= \
locale.dir locale.dir.l1 locale.dir.l2 \
XLC_LOCALE
-SUBDIRS= \
+locales = \
am_ET.UTF-8 \
armscii-8 \
C \
@@ -75,6 +75,8 @@ SUBDIRS= \
include $(top_srcdir)/cpprules.in
+# Global data files
+
locale.alias: locale.alias.pre
$(AM_V_GEN)$(RAWCPP) $(RAWCPPFLAGS) $(CPP_FILES_FLAGS) < $(srcdir)/locale.alias.pre | $(CPP_SED_MAGIC) > locale.alias.l1
sed -e '/^[^#][^ ]*:/s/://' -e '/^[^#].*[ ].*:/d' \
@@ -92,3 +94,21 @@ locale.dir: locale.dir.pre
sed -e '/^[^#][^ ]*:/s/://' -e '/^[^#].*[ ].*:/d' \
< locale.dir.l1 > locale.dir.l2
cat locale.dir.l2 locale.dir.l1 > locale.dir
+
+# Per-locale data files
+
+nobase_dist_x11locale_DATA = $(locales:%=%/XI18N_OBJS)
+
+nobase_x11locale_DATA = $(locales:%=%/XLC_LOCALE) $(locales:%=%/Compose)
+EXTRA_DIST += $(nobase_x11locale_DATA:%=%.pre)
+CLEANFILES += $(nobase_x11locale_DATA)
+
+$(nobase_x11locale_DATA): builddirs
+
+builddirs:
+ $(MKDIR_P) $(locales)
+
+if HAVE_PERL
+TESTS_ENVIRONMENT = $(PERL)
+TESTS = $(srcdir)/compose-check.pl
+endif HAVE_PERL