summaryrefslogtreecommitdiff
path: root/nls/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@sun.com>2005-07-09 18:44:14 +0000
committerAlan Coopersmith <alan.coopersmith@sun.com>2005-07-09 18:44:14 +0000
commit3939ac4410446b46071c9d714f4270c12bf904fe (patch)
tree51ec855dea94ae24d7882bd8bfcc0a5b86876e30 /nls/Makefile.am
parent19ba9d0df86c688319377467254b9ea9c4b0eccc (diff)
downloadxorg-lib-libX11-3939ac4410446b46071c9d714f4270c12bf904fe.tar.gz
- Since all but one line of all the nls/*/Makefile.am files are identical, move common bits to nls/localerules.in for easier updating and use automake includes to include in all the nls/*/Makefile.am files
- Don't assume $(CPP) can take gcc-only -traditional flag - CPP process man pages as is done in the monolithic tree
Diffstat (limited to 'nls/Makefile.am')
-rw-r--r--nls/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/nls/Makefile.am b/nls/Makefile.am
index 0945e34d..4183fb9a 100644
--- a/nls/Makefile.am
+++ b/nls/Makefile.am
@@ -68,12 +68,14 @@ SUBDIRS= \
zh_TW.big5 \
zh_TW.UTF-8
+include $(top_srcdir)/cpprules.in
+
locale.alias: locale.alias.pre
- $(CPP) -traditional -DXCOMM='#' - < $(srcdir)/locale.alias.pre > locale.alias.l1
+ $(RAWCPP) $(RAWCPPFLAGS) $(CPP_FILES_FLAGS) < $(srcdir)/locale.alias.pre | $(CPP_SED_MAGIC) > locale.alias.l1
sed -e '/^[^#][^ ]*:/s/://' -e '/^[^#].*[ ].*:/d' \
< locale.alias.l1 > locale.alias
compose.dir: compose.dir.pre
- $(CPP) -traditional -DXCOMM='#' - < $(srcdir)/compose.dir.pre > compose.dir.l1
+ $(RAWCPP) $(RAWCPPFLAGS) $(CPP_FILES_FLAGS) < $(srcdir)/compose.dir.pre | $(CPP_SED_MAGIC) > compose.dir.l1
sed -e '/^[^#][^ ]*:/s/://' -e '/^[^#].*[ ].*:/d' \
< compose.dir.l1 > compose.dir