summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@sun.com>2009-09-18 16:58:16 -0700
committerAlan Coopersmith <alan.coopersmith@sun.com>2009-09-18 17:13:04 -0700
commitbfa19cddd8546b4930a773f3bbd81137c362d82b (patch)
tree48205630e62b3077e3a6d32f6b35a26a2396b4c4 /configure.ac
parent51396066c8003a96a6399c9a4bed2a81e512b582 (diff)
downloadxorg-lib-libX11-bfa19cddd8546b4930a773f3bbd81137c362d82b.tar.gz
Update to using xorg-macros 1.3 & XORG_DEFAULT_OPTIONS
Signed-off-by: Alan Coopersmith <alan.coopersmith@sun.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 4 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index 3735837a..d6b50a00 100644
--- a/configure.ac
+++ b/configure.ac
@@ -14,9 +14,9 @@ AM_MAINTAINER_MODE
AM_CONFIG_HEADER([src/config.h])
AC_CONFIG_HEADER([include/X11/XlibConf.h])
-# Require xorg-macros: XORG_CWARNFLAGS, XORG_CHANGELOG, XORG_WITH_LINT
-m4_ifndef([XORG_MACROS_VERSION], [AC_FATAL([must install xorg-macros 1.2 or later before running autoconf/autogen])])
-XORG_MACROS_VERSION(1.2)
+# Require xorg-macros: XORG_DEFAULT_OPTIONS, XORG_CHANGELOG, XORG_WITH_LINT
+m4_ifndef([XORG_MACROS_VERSION], [AC_FATAL([must install xorg-macros 1.3 or later before running autoconf/autogen])])
+XORG_MACROS_VERSION(1.3)
# Set common system defines for POSIX extensions, such as _GNU_SOURCE
# Must be called before any macros that run the compiler (like AC_PROG_LIBTOOL)
@@ -27,7 +27,7 @@ AC_USE_SYSTEM_EXTENSIONS
AC_PROG_LIBTOOL
DOLT
AC_PROG_CC
-XORG_CWARNFLAGS
+XORG_DEFAULT_OPTIONS
if test x"$CC_FOR_BUILD" = x; then
if test x"$cross_compiling" = xyes; then
@@ -330,8 +330,6 @@ AC_ARG_ENABLE(xkb,
[Disable XKB support *EXPERIMENTAL*]),
[XKB=$enableval],[XKB=yes])
-XORG_MANPAGE_SECTIONS
-
AC_ARG_ENABLE(man-pages,
AC_HELP_STRING([--enable-man-pages=section],
[Choose manual section for installing man pages]),
@@ -419,10 +417,7 @@ AC_DEFINE_DIR(XKEYSYMDB, XKEYSYMDB, [Location of keysym database])
XERRORDB="${X11_DATADIR}/XErrorDB"
AC_DEFINE_DIR(XERRORDB, XERRORDB, [Location of error message database])
-
XORG_CHECK_MALLOC_ZERO
-XORG_RELEASE_VERSION
-XORG_CHANGELOG
AC_OUTPUT([Makefile
include/Makefile