summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@sun.com>2009-04-15 10:56:09 -0700
committerAlan Coopersmith <alan.coopersmith@sun.com>2009-09-18 17:13:05 -0700
commit3843778358d3a0cd6a2d07dba5dd061248053ac9 (patch)
tree49ac189cfe42081e21d075e7310e3bedaa1a84de /configure.ac
parent19cc5e1fa17a285045662820a8b4de2a0f9a194d (diff)
downloadxorg-lib-libX11-3843778358d3a0cd6a2d07dba5dd061248053ac9.tar.gz
Add perl script to check for duplicate or conflicting compose file entries
Signed-off-by: Alan Coopersmith <alan.coopersmith@sun.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 02e6f621..8bcbb32a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -40,6 +40,15 @@ AC_SUBST([CC_FOR_BUILD])
XORG_PROG_RAWCPP
+# Find perl for "make check" tests in nls/localerules.in
+AC_ARG_WITH(perl,
+ AC_HELP_STRING([--with-perl=<path>],
+ [path to perl interpreter for build-time tests]),
+ [PERL=$withval ; AC_MSG_CHECKING([perl]) ;
+ AC_MSG_RESULT([(from --with-perl) $PERL])],
+ AC_CHECK_PROGS([PERL], [perl], [no]))
+AM_CONDITIONAL(HAVE_PERL, test x$PERL != xno)
+
# Build with XCB support?
AC_ARG_WITH(xcb,
AC_HELP_STRING([--with-xcb], [use XCB for low-level protocol implementation]),