summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 13 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index af8b89e..3635d6b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -31,14 +31,26 @@ XTRANS_CONNECTION_FLAGS
AC_ARG_WITH(libuuid, AS_HELP_STRING([--with-libuuid], [Build with libuuid support for client IDs]))
+PKG_PROG_PKG_CONFIG()
AC_CHECK_FUNCS([uuid_create], [], [
if test x"$with_libuuid" != xno && test x"$have_system_uuid" != xyes; then
PKG_CHECK_MODULES(LIBUUID, uuid, [HAVE_LIBUUID=yes], [HAVE_LIBUUID=no])
fi
if test x"$with_libuuid" = xyes && test x"$HAVE_LIBUUID" = xno; then
- AC_MSG_ERROR([requested libuuid support but uuid.pc not found])
+ AC_MSG_ERROR([requested libuuid support but uuid.pc not found
+ and LIBUUID_CFLAGS and LIBUUID_LIBS not set])
fi
])
+UUID_LIB_PRIVATE=""
+UUID_PC=""
+if test x"$HAVE_LIBUUID" = xyes ; then
+ PKG_CHECK_EXISTS(uuid, [UUID_PC="uuid"])
+ if test x"$UUID_PC" = x ; then
+ UUID_LIB_PRIVATE="$LIBUUID_LIBS"
+ fi
+fi
+AC_SUBST([UUID_LIB_PRIVATE])
+AC_SUBST([UUID_PC])
AM_CONDITIONAL(WITH_LIBUUID, test x"$HAVE_LIBUUID" = xyes)