summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@sun.com>2006-07-11 13:48:08 -0700
committerAlan Coopersmith <alanc@alf.(none)>2006-07-11 13:48:08 -0700
commitc87cb98979356fc55607c05a2b23207afc9beeb1 (patch)
treea0703bab7ee35eea2cab4451859fe73ab72caed7 /Makefile.am
parent6066ab9b9914ec0cca3b8f36fa3f5ba323414621 (diff)
downloadxorg-lib-libICE-c87cb98979356fc55607c05a2b23207afc9beeb1.tar.gz
Replace static ChangeLog with rule copied from libX11 to generate from git log
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index ea360d3..62e5efd 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3,4 +3,13 @@ SUBDIRS = src
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = ice.pc
-EXTRA_DIST=ice.pc.in
+EXTRA_DIST=ice.pc.in ChangeLog
+
+CLEANFILES=ChangeLog
+
+.PHONY: ChangeLog
+
+ChangeLog:
+ git-log > ChangeLog
+
+dist-hook: ChangeLog