summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChris Wilson <chris@chris-wilson.co.uk>2015-03-04 15:28:49 +0000
committerChris Wilson <chris@chris-wilson.co.uk>2015-03-04 15:29:45 +0000
commit88e615425bd61856c3f039127fb90592dfac22df (patch)
treebac8dd84ffcc769b22b615137c76beed947b7446 /configure.ac
parent413ca2b88f6398d68d2a170bb24b1ea643b6ff30 (diff)
downloadxorg-driver-xf86-video-intel-88e615425bd61856c3f039127fb90592dfac22df.tar.gz
configure: Make sure that BUILD_TOOL_CURSOR is always defined
Building intel driver with --disable-tools fails with following configure: error: conditional "BUILD_TOOL_CURSOR" was never defined. Reported-by: Tomas Pruzina <pruzinat@gmail.com> Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=89425 Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index c5356e2f..28a47493 100644
--- a/configure.ac
+++ b/configure.ac
@@ -313,7 +313,6 @@ if test "x$tools" != "xno"; then
fi
PKG_CHECK_MODULES(TOOL_CURSOR, [xfixes x11 libpng], [cursor="yes"], [ivo="no"])
- AM_CONDITIONAL(BUILD_TOOL_CURSOR, test "x$cursor" != "xno")
IVO_CFLAGS="$IVO_CFLAGS $extra_cflags"
fi
@@ -323,6 +322,7 @@ fi
AC_MSG_CHECKING([whether to build additional tools])
AC_MSG_RESULT([$tools])
AM_CONDITIONAL(BUILD_TOOLS, test "x$tools" != "xno")
+AM_CONDITIONAL(BUILD_TOOL_CURSOR, test "x$cursor" = "xyes")
# Define a configure option for an alternate module directory
AC_ARG_WITH(xorg-module-dir,