summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChris Wilson <chris@chris-wilson.co.uk>2015-03-03 12:47:24 +0000
committerChris Wilson <chris@chris-wilson.co.uk>2015-03-03 12:47:24 +0000
commit555f7f4f54d60e99c8c00d7b3b1e574dc27ec68b (patch)
tree1ec30d56a32c82940e2d0bcbecec574a5bb1dd53 /configure.ac
parenta5978074dba200b4059f53ab94b9c34863250520 (diff)
downloadxorg-driver-xf86-video-intel-555f7f4f54d60e99c8c00d7b3b1e574dc27ec68b.tar.gz
configure: Include the xorg-server version in the summary
Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index cef24869..a7cdd93f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -443,6 +443,7 @@ fi
PKG_CHECK_MODULES(XORG, [xorg-server >= $required_xorg_server_version xproto fontsproto pixman-1 >= $required_pixman_version $REQUIRED_MODULES])
ABI_VERSION=`$PKG_CONFIG --variable=abi_videodrv xorg-server`
+XSERVER_VERSION=`$PKG_CONFIG --modversion xorg-server`
if test "x$ONLY_UMS" = "xyes"; then
UMS="yes"
@@ -909,7 +910,7 @@ fi
echo ""
echo "AC_PACKAGE_STRING will be compiled with:"
-echo " Xorg Video ABI version: $ABI_VERSION"
+echo " Xorg Video ABI version: $ABI_VERSION (xorg-server-$XSERVER_VERSION)"
echo " Acceleration backends:$accel_msg"
echo " Additional debugging support?$debug_msg"
echo " Support for Kernel Mode Setting? $KMS"