summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSøren Sandmann Pedersen <sandmann@daimi.au.dk>2005-07-15 18:02:35 +0000
committerSøren Sandmann Pedersen <sandmann@daimi.au.dk>2005-07-15 18:02:35 +0000
commitd7b3354575f31caa9044b6c5f7aee4f010f6192a (patch)
tree1c5f116d04ceca885355f32b62044434a7ec491f /Makefile.am
parent59e48918e7c252926bb5e51a077bcbc8a7eec829 (diff)
downloadxorg-app-xkbcomp-d7b3354575f31caa9044b6c5f7aee4f010f6192a.tar.gz
Build system for xkbcomp
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am63
1 files changed, 63 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..5c0356f
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,63 @@
+#
+# Copyright 2005 Red Hat, Inc.
+#
+# Permission to use, copy, modify, distribute, and sell this software and its
+# documentation for any purpose is hereby granted without fee, provided that
+# the above copyright notice appear in all copies and that both that
+# copyright notice and this permission notice appear in supporting
+# documentation, and that the name of Red Hat not be used in
+# advertising or publicity pertaining to distribution of the software without
+# specific, written prior permission. Red Hat makes no
+# representations about the suitability of this software for any purpose. It
+# is provided "as is" without express or implied warranty.
+#
+# RED HAT DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
+# INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO
+# EVENT SHALL RED HAT BE LIABLE FOR ANY SPECIAL, INDIRECT OR
+# CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
+# DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
+# TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
+# PERFORMANCE OF THIS SOFTWARE.
+
+bin_PROGRAMS = xkbcomp
+
+AM_CFLAGS = $(DEP_CFLAGS)
+xkbcomp_LDADD = $(DEP_LIBS)
+
+xkbcomp_SOURCES = \
+ action.c \
+ action.h \
+ alias.c \
+ alias.h \
+ compat.c \
+ compat.h \
+ expr.c \
+ expr.h \
+ geometry.c \
+ indicators.c \
+ indicators.h \
+ keycodes.c \
+ keycodes.h \
+ keymap.c \
+ keytypes.c \
+ listing.c \
+ misc.c \
+ misc.h \
+ parseutils.c \
+ parseutils.h \
+ symbols.c \
+ tokens.h \
+ utils.c \
+ utils.h \
+ vmod.c \
+ vmod.h \
+ xkbcomp.c \
+ xkbcomp.h \
+ xkbparse.c \
+ xkbpath.c \
+ xkbpath.h \
+ xkbscan.c
+
+dist_man_MANS = \
+ xkbcomp.man
+