summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <Alan.Coopersmith@sun.com>2005-10-14 00:25:46 +0000
committerAlan Coopersmith <Alan.Coopersmith@sun.com>2005-10-14 00:25:46 +0000
commita83e4bb777d6f9b1b42a7fb3ff84a5e0d7e123c7 (patch)
tree79fdf0007d2d543d41cd938bf0fc4e9f460038f0 /Makefile.am
parent8c0d310c1acccc424dae29554a5075f9b339e95f (diff)
downloadxorg-app-xkbcomp-a83e4bb777d6f9b1b42a7fb3ff84a5e0d7e123c7.tar.gz
Use sed to fill in variables in man page
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am33
1 files changed, 32 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index e9aec03..782ca22 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -58,7 +58,7 @@ xkbcomp_SOURCES = \
xkbpath.h \
xkbscan.c
-dist_man1_MANS = \
+appman_SOURCES = \
xkbcomp.man
BUILT_SOURCES = xkbparse.c xkbparse.h
@@ -69,3 +69,34 @@ xkbparse.h: xkbparse.c
EXTRA_DIST = \
README.config \
README.enhancing
+
+appmandir = $(mandir)/man$(APP_MAN_SUFFIX)
+
+appman_DATA = $(appman_SOURCES:man=$(APP_MAN_SUFFIX))
+
+EXTRA_DIST += $(appman_SOURCES)
+CLEANFILES += $(appman_DATA)
+
+SED = sed
+
+# Strings to replace in man pages
+XORGRELSTRING = @PACKAGE_STRING@
+ XORGMANNAME = X Version 11
+
+MAN_SUBSTS = \
+ -e 's|__vendorversion__|"$(XORGRELSTRING)" "$(XORGMANNAME)"|' \
+ -e 's|__xorgversion__|"$(XORGRELSTRING)" "$(XORGMANNAME)"|' \
+ -e 's|__xservername__|Xorg|g' \
+ -e 's|__xconfigfile__|xorg.conf|g' \
+ -e 's|__projectroot__|$(prefix)|g' \
+ -e 's|__apploaddir__|$(appdefaultdir)|' \
+ -e 's|__appmansuffix__|$(APP_MAN_SUFFIX)|g' \
+ -e 's|__libmansuffix__|$(LIB_MAN_SUFFIX)|g' \
+ -e 's|__adminmansuffix__|$(ADMIN_MAN_SUFFIX)|g' \
+ -e 's|__miscmansuffix__|$(MISC_MAN_SUFFIX)|g' \
+ -e 's|__filemansuffix__|$(FILE_MAN_SUFFIX)|g'
+
+SUFFIXES = .$(APP_MAN_SUFFIX) .man
+
+.man.$(APP_MAN_SUFFIX):
+ sed $(MAN_SUBSTS) < $< > $@