summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJames Cloos <cloos@jhcloos.com>2007-12-06 16:37:18 -0500
committerJames Cloos <cloos@jhcloos.com>2007-12-06 16:37:18 -0500
commit686e8b6d33602f5fb7de7a768e532a4ac8090c26 (patch)
tree7bcdac035626895873c9291c712370b9899a5f35 /Makefile.am
parent6aae208fe5bd8f71757c294a441d7c599a1ec4a1 (diff)
downloadxorg-app-xkbcomp-686e8b6d33602f5fb7de7a768e532a4ac8090c26.tar.gz
Replace static ChangeLog with dist-hook to generate from git log
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 3e63535..5a825f5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -98,3 +98,13 @@ SUFFIXES = .$(APP_MAN_SUFFIX) .man
.man.$(APP_MAN_SUFFIX):
sed $(MAN_SUBSTS) < $< > $@
+
+EXTRA_DIST += ChangeLog
+MAINTAINERCLEANFILES = ChangeLog
+
+.PHONY: ChangeLog
+
+ChangeLog:
+ (GIT_DIR=$(top_srcdir)/.git git-log > .changelog.tmp && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) || (touch ChangeLog; echo 'git directory not found: installing possibly empty changelog.' >&2)
+
+dist-hook: ChangeLog