summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJeremy Huddleston <jeremyhu@apple.com>2011-05-11 00:24:45 -0700
committerJeremy Huddleston <jeremyhu@apple.com>2011-05-11 00:24:45 -0700
commitc8b40e87f69f5be881725388418d703116af8e5f (patch)
tree2128cde77e3131f0fdba5f18a4915256335674b9 /configure.ac
parent50f1172349dc900da4016c243734ae50691eab6c (diff)
downloadxorg-app-xinit-c8b40e87f69f5be881725388418d703116af8e5f.tar.gz
Rename launchd-id-prefix to bundle-id-prefix
It's used many other places than just for launchd. Signed-off-by: Jeremy Huddleston <jeremyhu@apple.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 8 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index d9c795d..15bcc12 100644
--- a/configure.ac
+++ b/configure.ac
@@ -104,9 +104,12 @@ AC_ARG_WITH(launchagents-dir, AS_HELP_STRING([--with-launchagents-dir=PATH], [
AC_ARG_WITH(launchdaemons-dir, AS_HELP_STRING([--with-launchdaemons-dir=PATH], [Path to launchd's LaunchDaemonss directory (default: /Library/LaunchDaemons)]),
[ launchdaemonsdir="${withval}" ],
[ launchdaemonsdir="/Library/LaunchDaemons" ])
-AC_ARG_WITH(launchd-id-prefix, AS_HELP_STRING([--with-launchd-id-prefix=PATH], [Prefix to use for launchd identifiers (default: org.x)]),
- [ launchdidprefix="${withval}" ],
- [ launchdidprefix="org.x" ])
+AC_ARG_WITH(launchd-id-prefix, AS_HELP_STRING([--with-launchd-id-prefix=PATH], [Deprecated: Use --with-bundle-id-prefix.]),
+ [ bundleidprefix="${withval}" ],
+ [ bundleidprefix="org.x" ])
+AC_ARG_WITH(bundle-id-prefix, AS_HELP_STRING([--with-bundle-id-prefix=PATH], [Prefix to use for bundle identifiers (default: org.x)]),
+ [ bundleidprefix="${withval}" ],
+ [ bundleidprefix="org.x" ])
if test "x$LAUNCHD" = "xauto"; then
unset LAUNCHD
@@ -126,10 +129,10 @@ else
launchdaemonsdir=""
fi
-AC_DEFINE_UNQUOTED(LAUNCHD_ID_PREFIX, "$launchdidprefix", [Prefix to use for launchd identifiers])
+AC_DEFINE_UNQUOTED(BUNDLE_ID_PREFIX, "$bundleidprefix", [Prefix to use for launchd identifiers])
AC_SUBST([launchagentsdir])
AC_SUBST([launchdaemonsdir])
-AC_SUBST([launchdidprefix])
+AC_SUBST([bundleidprefix])
AM_CONDITIONAL(LAUNCHD, [test "x$LAUNCHD" = "xyes"])
AM_CONDITIONAL(TIGER_LAUNCHD, [test "x$TIGER_LAUNCHD" = "xyes"])