summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJeremy Huddleston <jeremyhu@freedesktop.org>2009-09-02 10:43:25 -0700
committerJeremy Huddleston <jeremyhu@freedesktop.org>2009-09-02 10:43:25 -0700
commit78d181dc74ffb3e67ee0d90780b86e00e03073eb (patch)
treeaf4fc08567fb47e2b7f8c053cdb2dedd5174d5f8 /configure.ac
parent33c3dae16b632ab56b6b361273a48079eb0a41c4 (diff)
downloadxorg-app-xinit-78d181dc74ffb3e67ee0d90780b86e00e03073eb.tar.gz
launchd: Added --with-launchd-id-prefix option to set non-standard launchd id prefix (org.x is still default)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7e2fb82..7f354f9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -105,6 +105,9 @@ AC_ARG_WITH(launchagents-dir, AS_HELP_STRING([--with-launchagents-dir=PATH], [
AC_ARG_WITH(launchdaemons-dir, AS_HELP_STRING([--with-launchdaemons-dir=PATH], [Path to launchd's LaunchDaemonss directory (default: /Library/LaunchDaemons)]),
[ launchdaemonsdir="${withval}" ],
[ launchdaemonsdir="/Library/LaunchDaemons" ])
+AC_ARG_WITH(launchd-id-prefix, AS_HELP_STRING([--with-launchd-id-prefix=PATH], [Prefix to use for launchd identifiers (default: org.x)]),
+ [ launchdidprefix="${withval}" ],
+ [ launchdidprefix="org.x" ])
if test "x$LAUNCHD" = "xauto"; then
unset LAUNCHD
@@ -123,8 +126,11 @@ else
launchagentsdir=""
launchdaemonsdir=""
fi
+
+AC_DEFINE_UNQUOTED(LAUNCHD_ID_PREFIX, "$launchdidprefix", [Prefix to use for launchd identifiers])
AC_SUBST([launchagentsdir])
AC_SUBST([launchdaemonsdir])
+AC_SUBST([launchdidprefix])
AM_CONDITIONAL(LAUNCHD, [test "x$LAUNCHD" = "xyes"])
AM_CONDITIONAL(TIGER_LAUNCHD, [test "x$TIGER_LAUNCHD" = "xyes"])