summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJeremy Huddleston <jeremyhu@freedesktop.org>2008-04-17 17:19:41 -0700
committerJeremy Huddleston <jeremyhu@freedesktop.org>2008-04-17 17:19:41 -0700
commit2b06b58a328e13df4704df8a48d4cd0b1100ba7e (patch)
treef78229fab2f19f9de084ff09206cd57c65c95504 /configure.ac
parentfe5af014f2645d1ecf981d40d3c10a3621e9ec56 (diff)
downloadxorg-app-xinit-2b06b58a328e13df4704df8a48d4cd0b1100ba7e.tar.gz
Apple: Added privileged_startx
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 8 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index f473580..f33fd13 100644
--- a/configure.ac
+++ b/configure.ac
@@ -92,12 +92,13 @@ AC_ARG_WITH(xinit,
[XINIT="$withval"],
[XINIT="$DEFAULT_XINIT"])
-AC_ARG_WITH(launchd, AS_HELP_STRING([--with-launchd], [Build with suppo
-rt for Apple's launchd (default: auto)]), [LAUNCHD=$withval], [LAUNCHD=auto])
-AC_ARG_WITH(launchagents-dir,AS_HELP_STRING([--with-launchagents-dir=PATH], [Pat
-h to launchd's LaunchAgents directory (default: /Library/LaunchAgents)]),
+AC_ARG_WITH(launchd, AS_HELP_STRING([--with-launchd], [Build with support for Apple's launchd (default: auto)]), [LAUNCHD=$withval], [LAUNCHD=auto])
+AC_ARG_WITH(launchagents-dir, AS_HELP_STRING([--with-launchagents-dir=PATH], [Path to launchd's LaunchAgents directory (default: /Library/LaunchAgents)]),
[ launchagentsdir="${withval}" ],
[ launchagentsdir="/Library/LaunchAgents" ])
+AC_ARG_WITH(launchdaemons-dir, AS_HELP_STRING([--with-launchdaemons-dir=PATH], [Path to launchd's LaunchDaemonss directory (default: /Library/LaunchDaemons)]),
+ [ launchdaemonsdir="${withval}" ],
+ [ launchdaemonsdir="/Library/LaunchDaemons" ])
if test "x$LAUNCHD" = "xauto"; then
unset LAUNCHD
@@ -121,8 +122,10 @@ if test "x$LAUNCHD" = "xyes" ; then
else
AM_CONDITIONAL(APPLE,false)
launchagentsdir=""
+ launchdaemonsdir=""
fi
AC_SUBST([launchagentsdir])
+AC_SUBST([launchdaemonsdir])
AM_CONDITIONAL(LAUNCHD, [test "x$LAUNCHD" = "xyes"])
# Checks for pkg-config packages
@@ -182,3 +185,4 @@ XORG_MANPAGE_SECTIONS
XORG_RELEASE_VERSION
AC_OUTPUT([Makefile])
+AC_OUTPUT([privileged_startx/Makefile])