summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJeremy Huddleston <jeremyhu@freedesktop.org>2008-04-25 19:00:23 -0700
committerJeremy Huddleston <jeremyhu@freedesktop.org>2008-04-25 19:00:23 -0700
commit280774466dc9f57b4b46c618345f7938290dbb2c (patch)
treed0a5d2fe26d96a1b5f185dee7cc67e952b52450b /configure.ac
parent0806ae2ecfdcb4ad5f3b7a66dcc9bc5d29d72649 (diff)
downloadxorg-app-xinit-280774466dc9f57b4b46c618345f7938290dbb2c.tar.gz
Apple: Added some OSX version protection, so this will still compile on Tiger and below.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 4 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index f33fd13..b476c1c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -109,18 +109,15 @@ if test "x$LAUNCHD" = "xyes" ; then
AC_DEFINE(HAVE_LAUNCHD, 1, [launchd support available])
case $host_os in
- darwin*)
- # For now, this is how we find X11.app on OS-X...
- # A future version of launchd should let us do this cleaner
- #XSERVER=\'\`'$(libexecdir)/x11-exec'\`\'
- AM_CONDITIONAL(APPLE, true)
+ darwin9*|darwin1*)
+ AM_CONDITIONAL(APPLE_LEOPARD, true)
;;
*)
- AM_CONDITIONAL(APPLE, false)
+ AM_CONDITIONAL(APPLE_LEOPARD, false)
;;
esac
else
- AM_CONDITIONAL(APPLE,false)
+ AM_CONDITIONAL(APPLE_LEOPARD,false)
launchagentsdir=""
launchdaemonsdir=""
fi