summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <Alan.Coopersmith@sun.com>2005-07-16 23:29:38 +0000
committerAlan Coopersmith <Alan.Coopersmith@sun.com>2005-07-16 23:29:38 +0000
commitd8980cb7b6df64cf92c5b660f838497296dbb0bb (patch)
tree2d7292126c30dd39a6cac338d441b4619a3bf13c /Makefile.am
parentd731a249d0c1c7f9eb77828c0d6e79cfdaf75589 (diff)
downloadxorg-app-xinit-d8980cb7b6df64cf92c5b660f838497296dbb0bb.tar.gz
x11perf/Makefile.am: xinit/Makefile.am: xvidtune/Makefile.am:
- Replace $< with portable macro xinit/Makefile.am: xinit/configure.ac: xvidtune/Makefile.am: xvidtune/configure.ac: - Use more portable cpp invocations for pre-processing files xfs/configure.ac: - Add XTRANS_CONNECTION_FLAGS so xtrans transport type defines are set correctly
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 50903dd..414b166 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -37,10 +37,10 @@ dist_man_MANS = \
xinitrcdir = $(XINITDIR)
xinitrc: xinitrc.cpp
- $(SED) s/XINITDIR/`echo $(XINITDIR) | sed -e s/\\\\//\\\\\\\\\\\\\//g`/ < $< | $(SED) s/XCOMM/\#/ > $@
+ $(SED) s/XINITDIR/`echo $(XINITDIR) | sed -e s/\\\\//\\\\\\\\\\\\\//g`/ < $(srcdir)/xinitrc.cpp | $(SED) s/XCOMM/\#/ > $@
startx: startx.cpp Makefile
- $(CPP) -DXINITDIR=$(XINITDIR) -DBINDIR=$(bindir) $< | $(SED) -e /^\#/d | $(SED) -e s/XCOMM/\#/ > $@
+ $(RAWCPP) -DXINITDIR=$(XINITDIR) -DBINDIR=$(bindir) $(srcdir)/startx.cpp | $(SED) -e /^\#/d | $(SED) -e s/XCOMM/\#/ > $@
xinitrc_DATA = xinitrc