summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPaulo Cesar Pereira de Andrade <pcpa@mandriva.com.br>2009-01-21 19:22:31 -0200
committerPaulo Cesar Pereira de Andrade <pcpa@mandriva.com.br>2009-01-21 19:22:31 -0200
commitc30b10caedf7bdafb9abda914f80c90bfaccaec5 (patch)
tree7b309dd856425f161f987ad0aa2139f9a7e84879 /Makefile.am
parent57f917f8934d441ebb6501c4691a2b59fa217f3f (diff)
downloadxorg-app-xinit-c30b10caedf7bdafb9abda914f80c90bfaccaec5.tar.gz
Correct make distcheck for recent git versions.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 0d831f3..951d51a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -24,7 +24,7 @@ XINITDIR = $(libdir)/X11/xinit
bin_PROGRAMS = xinit
bin_SCRIPTS = startx
-xinit_CFLAGS = $(XINIT_CFLAGS) -DXINITDIR=\"$(XINITDIR)\" -DBINDIR=\"$(bindir)\"
+AM_CFLAGS = $(XINIT_CFLAGS) -DXINITDIR=\"$(XINITDIR)\" -DBINDIR=\"$(bindir)\"
xinit_LDADD = $(XINIT_LIBS)
xinit_SOURCES = \
@@ -77,6 +77,6 @@ EXTRA_DIST = xinitrc.cpp startx.cpp org.x.startx.plist.cpp $(appman_PRE) \
.PHONY: ChangeLog
ChangeLog:
- (GIT_DIR=$(top_srcdir)/.git git-log > .changelog.tmp && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) || (touch ChangeLog; echo 'git directory not found: installing possibly empty changelog.' >&2)
+ $(CHANGELOG_CMD)
dist-hook: ChangeLog