summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorEric Anholt <anholt@freebsd.org>2005-08-11 18:11:32 +0000
committerEric Anholt <anholt@freebsd.org>2005-08-11 18:11:32 +0000
commit52fb36b1ec52e78916bf9cf1a5e7bdce05482b0c (patch)
treea7147e15c6577cd168e7b99573bdc125566e5a96 /Makefile.am
parentef53714d87aa71309fe2f22862f1892a8e620336 (diff)
downloadxorg-app-xinit-52fb36b1ec52e78916bf9cf1a5e7bdce05482b0c.tar.gz
Bugzilla #4045: Do a missed replacement of @@ with \ in startx.
Submitted by: David Schleef <ds@schleef.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index d202173..152331d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -40,7 +40,7 @@ xinitrc: xinitrc.cpp
$(SED) s/XINITDIR/`echo $(XINITDIR) | sed -e s/\\\\//\\\\\\\\\\\\\//g`/ < $(srcdir)/xinitrc.cpp | $(SED) s/XCOMM/\#/ > $@
startx: startx.cpp Makefile
- $(RAWCPP) -DXINITDIR=$(XINITDIR) -DBINDIR=$(bindir) $(srcdir)/startx.cpp | $(SED) -e /^\#/d | $(SED) -e s/XCOMM/\#/ > $@
+ $(RAWCPP) -DXINITDIR=$(XINITDIR) -DBINDIR=$(bindir) $(srcdir)/startx.cpp | $(SED) -e /^\#/d | $(SED) -e s/XCOMM/\#/ | $(SED) -e 's/@@/\\/' > $@
xinitrc_DATA = xinitrc