summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorKevin E Martin <kem@kem.org>2005-11-15 04:05:59 +0000
committerKevin E Martin <kem@kem.org>2005-11-15 04:05:59 +0000
commit0a06386696875638e9e9b6e47e95affbf542e25d (patch)
tree11ff35717894f8c0f75a9f333e994f5d6adf7c93 /Makefile.am
parent549c55ea15e60b9aca5da1ed6f18564f1e69cd26 (diff)
downloadxorg-app-xinit-0a06386696875638e9e9b6e47e95affbf542e25d.tar.gz
Make the programs used in the xinit scripts configurable.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 26f0c0b..366cae1 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -73,8 +73,18 @@ SUFFIXES = .$(APP_MAN_SUFFIX) .man
xinitrcdir = $(XINITDIR)
+PROGCPPDEFS = \
+ -DXRDB=@XRDB@ \
+ -DXMODMAP=@XMODMAP@ \
+ -DTWM=@TWM@ \
+ -DXCLOCK=@XCLOCK@ \
+ -DXTERM=@XTERM@ \
+ -DXSERVER=@XSERVER@ \
+ -DXAUTH=@XAUTH@ \
+ -DXINIT=@XINIT@
+
SCRIPTDEFS = \
- -DXINITDIR=$(XINITDIR) -DBINDIR=$(bindir) -DLIBDIR=$(libdir) \
+ -DXINITDIR=$(XINITDIR) $(PROGCPPDEFS) -DLIBDIR=$(libdir) \
-DSHELL_CMD=$(SHELL_CMD) $(STARTX_COOKIE_FLAGS)
xinitrc: xinitrc.cpp