summaryrefslogtreecommitdiff
path: root/rules/meson.build
diff options
context:
space:
mode:
authorPeter Hutterer <peter.hutterer@who-t.net>2021-04-20 17:39:50 +1000
committerPeter Hutterer <peter.hutterer@who-t.net>2021-04-27 01:24:09 +0000
commitff3dcb932024ed13341938cded04142eda94600e (patch)
treea6ceb1692460a90f73f0e2c9c77acb6d6346b9c9 /rules/meson.build
parent54ca9223e605824229deab67437d82be6bb478ab (diff)
downloadxkeyboard-config-ff3dcb932024ed13341938cded04142eda94600e.tar.gz
meson.build: add option to install the legacy xorg symlinks
console-setup still relies on the xorg ruleset [1] and there may be other tools out there. Let's provide an equivalent option to our autotools build to install the xorg symlinks. Note that unlike the autotools approach, only the "xorg" symlinks are provided, not the well and truly legacy "xfree86" ones. [1] https://salsa.debian.org/installer-team/console-setup/-/merge_requests/7/ Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
Diffstat (limited to 'rules/meson.build')
-rw-r--r--rules/meson.build7
1 files changed, 7 insertions, 0 deletions
diff --git a/rules/meson.build b/rules/meson.build
index c992f2e..7280560 100644
--- a/rules/meson.build
+++ b/rules/meson.build
@@ -164,8 +164,15 @@ foreach ruleset: ['base', 'evdev']
output: lst_file,
install: true,
install_dir: dir_xkb_rules)
+
endforeach
+if get_option('xorg-rules-symlinks')
+ foreach suffix: ['', '.lst', '.xml']
+ meson.add_install_script('sh', '-c',
+ 'ln -s base@0@ $DESTDIR@1@/xorg@0@'.format(suffix, dir_xkb_rules))
+ endforeach
+endif
# Copy the DTD to the build directory, the man page generation expects it in
# the same directory as the input XML file.
configure_file(output: 'xkb.dtd',