summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorOlivier Fourdan <fourdan.olivier@wanadoo.fr>2002-05-23 22:24:07 +0000
committerOlivier Fourdan <fourdan.olivier@wanadoo.fr>2002-05-23 22:24:07 +0000
commita8704e5f0674a8e5d6a9be5f548fa80d8953e621 (patch)
tree4623a43842a120fd44f0c11f88fe53728089aff6 /Makefile.am
parent63601f619f381f83e83cee0a8bff01992137f9df (diff)
downloadxfwm4-a8704e5f0674a8e5d6a9be5f548fa80d8953e621.tar.gz
Improve build process, add automatic xfwm4.spec generation
(Old svn revision: 10335)
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 10 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 16ffba294..fbccee1c7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,6 +1,14 @@
-EXTRA_DIST = example.xfwm4rc
+@SET_MAKE@
+
+EXTRA_DIST = example.xfwm4rc example.xfwm4rc.in xfwm4.spec xfwm4.spec.in
SUBDIRS = src defaults themes
distclean-local:
- rm -f example.xfwm4rc
+ rm -f example.xfwm4rc xfwm4.spec
+
+example.xfwm4rc :
+ @sed -e "s%_pkgdatadir_%$(pkgdatadir)%g" example.xfwm4rc.in > example.xfwm4rc
+
+rpm : dist
+ rpm -ta $(PACKAGE)-$(VERSION).tar.gz