summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorNick Schermer <nick@xfce.org>2010-06-01 17:48:12 +0200
committerNick Schermer <nick@xfce.org>2010-06-01 17:48:12 +0200
commit5ba6bcdf3efa7df56757010ef4a9782423e6f416 (patch)
tree23ed2d58a491e1b300e1ceffee5048cc99c26631 /Makefile.am
parente4b28e58a6722e3f56e661c71559438af5395fd6 (diff)
downloadxfwm4-5ba6bcdf3efa7df56757010ef4a9782423e6f416.tar.gz
Build ChangeLog from GIT.
Also drop po ChangeLog now we use Transifex. Conflicts: ChangeLog po/ChangeLog
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 18bb5a7b6..7cbb6cf81 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -49,3 +49,12 @@ snapshot: dist
snapshot-bz2: dist-bz2
mv $(PACKAGE)-$(VERSION).tar.bz2 \
$(PACKAGE)-$(VERSION)-r@REVISION@.tar.bz2
+
+.PHONY: ChangeLog
+
+ChangeLog: Makefile
+ (GIT_DIR=$(top_srcdir)/.git git log > .changelog.tmp \
+ && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) \
+ || (touch ChangeLog; echo 'Git directory not found: installing possibly empty changelog.' >&2)
+
+dist-hook: ChangeLog