summaryrefslogtreecommitdiff
path: root/common/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'common/Makefile.am')
-rw-r--r--common/Makefile.am30
1 files changed, 28 insertions, 2 deletions
diff --git a/common/Makefile.am b/common/Makefile.am
index 60078dd..04ebcc4 100644
--- a/common/Makefile.am
+++ b/common/Makefile.am
@@ -14,6 +14,11 @@ libxfconf_common_la_CFLAGS = \
-I$(top_srcdir) \
$(GLIB_CFLAGS)
+libxfconf_built_sources = \
+ xfconf-alias.h \
+ xfconf-aliasdef.c
+
+
if MAINTAINER_MODE
BUILT_SOURCES = \
@@ -23,15 +28,36 @@ BUILT_SOURCES = \
xfconf-marshal.h: stamp-xfconf-marshal.h
@true
stamp-xfconf-marshal.h: xfconf-marshal.list Makefile
- glib-genmarshal --prefix=xfconf_marshal xfconf-marshal.list --header > xfconf-marshal.h
+ glib-genmarshal --prefix=xfconf_marshal --internal xfconf-marshal.list --header > xfconf-marshal.h
echo timestamp > $(@F)
xfconf-marshal.c: xfconf-marshal.list Makefile
echo '#include "xfconf-marshal.h"' > xfconf-marshal.c
- glib-genmarshal --prefix=xfconf_marshal xfconf-marshal.list --body >> xfconf-marshal.c
+ glib-genmarshal --prefix=xfconf_marshal --internal xfconf-marshal.list --body >> xfconf-marshal.c
+
+
+
+CLEANFILES = \
+ actual-abi \
+ expected-abi
+
+DISTCLEANFILES = \
+ $(libxfconf_built_sources)
+
+BUILT_SOURCES += \
+ $(libxfconf_built_sources)
+
+xfconf-alias.h: make-exo-alias.pl $(top_srcdir)/xfconf/xfconf.symbols
+ $(PERL) $(srcdir)/make-exo-alias.pl <$(top_srcdir)/xfconf/xfconf.symbols >xfconf-alias.h
+
+xfconf-aliasdef.c: make-exo-alias.pl $(top_srcdir)/xfconf/xfconf.symbols
+ $(PERL) $(srcdir)/make-exo-alias.pl -def <$(top_srcdir)/xfconf/xfconf.symbols >xfconf-aliasdef.c
endif
EXTRA_DIST = \
+ make-exo-alias.pl \
+ xfconf-alias.h \
+ xfconf-aliasdef.c \
xfconf-dbus.xml \
xfconf-marshal.list